Issue with Workday

Incident Report for Colby College IT Services

Resolved

The issue with Workday has been successfully resolved. If you are still experiencing an issue, please contact the ITS Support Center at support@colby.edu or 207-859-4222
Posted Mar 17, 2025 - 16:40 EDT

Investigating

ITS is investigating an issue with Workday and will provide more information regularly via https://its-status.colby.edu.
Posted Mar 17, 2025 - 15:16 EDT
This incident affected: Workday.