Issue with several web services

Incident Report for Colby College IT Services

Resolved

The issue with the web services has been successfully resolved. If you are still experiencing an issue, please contact the ITS Support Center at support@colby.edu or 207-859-4222
Posted Jun 12, 2025 - 22:02 EDT

Identified

ITS has identified an issue with several web services and is working with the vendor (Cloudflare) to resolve the problem as soon as possible. We will continue to provide updates via https://its-status.colby.edu.
Posted Jun 12, 2025 - 15:37 EDT
This incident affected: Colby Websites (Colby Main Website, Cloudflare, Facilities Work Orders).