Issue with campus Internet service
Incident Report for Colby College IT Services
Resolved
The issue with campus network service has been successfully resolved. If you are still experiencing an issue, please contact us via support@colby.edu.
Posted Aug 09, 2022 - 23:20 EDT
Investigating
ITS is investigating an issue with campus Internet service and will provide more information regularly via https://its-status.colby.edu.
Posted Aug 09, 2022 - 22:26 EDT
This incident affected: Network Access (Campus Networks, VPN).