Issue with Workday
Incident Report for Colby College IT Services
Resolved
The issue with Workday has been successfully resolved. If you are still experiencing an issue, please contact the ITS Support Center at support@colby.edu or 207-859-4222
Posted Oct 02, 2024 - 08:05 EDT
Monitoring
Workday has been restored by the vendor and is now being monitored for successful resolution. If you are still experiencing an issue, please contact the ITS Support Center at support@colby.edu or 207-859-4222
Posted Oct 01, 2024 - 17:30 EDT
Update
ITS is continuing to investigate an issue with Workday and will provide more information regularly via https://its-status.colby.edu.
Posted Oct 01, 2024 - 14:59 EDT
Investigating
ITS is investigating an issue with Workday and will provide more information regularly via https://its-status.colby.edu.
Posted Oct 01, 2024 - 13:37 EDT
This incident affected: Workday.